File server work sometimes

1. My Caddy version (caddy version):

v2.0.0-rc.1 h1:DxUlg4kMisXwXVnWND7KEPl1f+vjFpIOzYpKpfmwyj8=

2. How I run Caddy:

cd test-caddy
caddy run

a. System environment:

Windows server 2019

d. My complete Caddyfile or JSON config:

root * .
file_server browse

3. The problem I’m having:

Hello everyone, the problem is that it only works sometimes, randomly,

4. Error messages and/or full log output:

C:\Users\Administrator\Desktop>cd test-caddy

C:\Users\Administrator\Desktop\test-caddy>caddy run
2020/04/07 13:44:24.285 e[34mINFOe[0m using adjacent Caddyfile
2020/04/07 13:44:24.298 e[34mINFOe[0m admin admin endpoint started {“address”: “localhost:2019”, “enforce_origin”: false, “origins”: [“localhost:2019”]}
2020/04/07 13:44:24.300 e[34mINFOe[0m http server is listening only on the HTTPS port but has no TLS connection policies; adding one to enable TLS {“server_name”: “srv0”, “https_port”: 443}
2020/04/07 13:44:24.300 e[34mINFOe[0m http enabling automatic HTTP->HTTPS redirects {“server_name”: “srv0”}
2020/04/07 13:44:24.304 e[34mINFOe[0m http enabling automatic TLS certificate management {“domains”: [“”]}
2020/04/07 13:44:24.348 e[34mINFOe[0m tls cleaned up storage units
2020/04/07 13:44:24.349 e[34mINFOe[0m autosaved config {“file”: “C:\Users\Administrator\AppData\Roaming\Caddy\autosave.json”}
2020/04/07 13:44:24.350 e[34mINFOe[0m serving initial configuration
2020/04/07 15:44:24 [INFO][cache:0xc0003736d0] Started certificate maintenance routine

Error in one pc on the same internet connection

Error on the same server

5. What I already tried:

I tried to check the ports of the router, firewall,
I want to specify that on Route 53 I simply made an ‘A’ record to my public ip address … I’m not sure it’s correct
If I access my site from a mobile phone with a mobile network it always works, from my computer it usually doesn’t …

I’m a beginner with caddy,
Thank you,


Try setting your host manually:

if it does work from outside, it may be a router problem, or some kind of DNS-Cache issue. Most problems of DNS resolve thmeselves after chache is expired :wink:

or try set another dns server on your router? or set another dns server on your client (maybe

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.