Error updating old caddy version to V1 on a server

1. My Caddy version (caddy -version):

Caddy 0.10.2

2. How I run Caddy:

As an service on Linux (systemd).

a. System environment:

CentOS Linux release 7.2.1511 (Core)

c. Service/unit/compose file:

Description=Caddy webserver

ExecStart=/bin/caddy -agree -email -pidfile=/var/run/  -conf=/var/bmss/caddy.conf -log=/var/bmss/errorlog/error.log
ExecReload=/bin/kill -USR1 $MAINPID


d. My complete Caddyfile:,,, (and 3000 more domains later...) {
    proxy / localhost:8080 {


    tls {
        max_certs 2000

http://*  * {
    proxy / localhost:8080 {
    header / {
        Via "1.1 google"

	timeouts 0
    tls off    

3. The problem I’m having:

I’ve placed the new caddy binary file in bin folder and restarting the caddy service. After the restart it says the service failed and exited.

4. Error messages and/or full log output:

I get multiple Warnings with following text: WARNING: The max_certs subdirective is now deprecated and offers no protection; please use ask instead.
After that I get: caddy.service: main process exited, code=exited, status=1/FAILURE
Unit caddy.service entered failed state. caddy.service failed.

5. What I already tried:

I tried to change max_certs to: “ask http://localhost:8080/allowed” because of the warning text, but the service still fails with the new caddy version.

I believe I may have solved this issue… Replying when it’s fully solved.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.