ERR_TOO_MANY_REDIRECTS... looping... again

I suck so much at proxing. I’ve set up a test site so I could try the things out and I get ERR_TOO_MANY_REDIRECTS. I’m even more confused as a setup on another VPS that looks identical (except domain name) worked.

Your suggestions what’s wrong and how to troubleshoot such things are greatly appreciated.

Here’s my Caddyfile:

test.mydomainname.blog {
    header {
	X-Robots-Tag "none"
	-Server
    }
    tls {
	dns cloudflare {env.CF_API_TOKEN}
	resolvers 1.1.1.1
    }
    reverse_proxy helloworld 
}

I’m running Caddy version 2.8.4 .
It’s being run inside Podman container - along with helloworls nginx demo.
Here’s the compose.yaml file:

---
networks:
  caddynet:
    name: caddynet
    driver: bridge
      #  authnet:
      #name: authnet
      #internal: true

services:
  caddy:
    name: caddy
    image: caddy-cloudflare
    restart: always
    env_file:
      - $PWD/.ENV/.caddy
    cap_add:
      - NET_ADMIN
    ports:
      - "80:80"
      - "443:443"
      - "443:443/udp"
    volumes:
      - $PWD/Caddyfile:/etc/caddy/Caddyfile:z
      -$PWD/Caddy/site:/srv:z
      - $PWD/Caddy/caddy_data:/data:z
      - $PWD/Caddy/caddy_config:/config:z
    networks:
      - caddynet

  helloworld:
    image: nginxdemos/hello
    restart: always
    name: helloworld
    networks:
      - caddynet
...

Is your domain “orange-clouded” on Cloudflare? (i.e. proxied by Cloudflare)

If so, it must be set to “SSL - Strict” or whatever they call it these days.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.