DNS01 Challenge - Recursive Nameservers

1. Caddy version (caddy version):


2. How I run Caddy:

Docker Swarm

a. System environment:


b. Command:


c. Service/unit/compose file:


d. My complete Caddyfile or JSON config:


3. The problem I’m having:

I want to find out whether the Caddy tls configuration supports the “–dns01-recursive-nameservers” option to solve the following issue:


Split DNS for internal queries (non authoritative) and external queries (acme challenges - authoritative).
The issue occurs once the client has inserted the txt record into the Cloudflare and attempts to validate it but the internal zone doesn’t have the record and therefore the validation times out.

4. Error messages and/or full log output:


5. What I already tried:

6. Links to relevant resources:


Also could you advise how I can go about switching to the libdns package as I am currently using the Caddy lego provider (GitHub - caddy-dns/lego-deprecated: (DEPRECATED) DNS modules so Caddy can solve the ACME DNS challenge with over 75 providers).

An example Caddyfile would be awesome.

Thank you!

Hi form,

Is there any update on this issue as I am having a similar problem.

This can be resolved.

This topic was automatically closed after 30 days. New replies are no longer allowed.