Client cert auth failing on iOS with Caddy 2

1. Caddy version (caddy version): 2

2. How I run Caddy:

Via official docker on unRAID. Forwarding /etc/caddy to /mnt/user/appdata/caddy on unRAID.

a. System environment:

unRAID with Docker

c. Service/unit/compose file:

/usr/local/emhttp/plugins/dynamix.docker.manager/scripts/docker run -d --name='caddy' --net='br0' --ip='' -e TZ="Europe/Stockholm" -e HOST_OS="Unraid" -v '/mnt/user/appdata/caddy/conf':'/etc/caddy':'rw' -v '/mnt/user/public/':'/mnt/user/public/':'rw' -v '/mnt/user/recordings/':'/mnt/user/recordings/':'rw' 'caddy' 

d. My complete Caddyfile or JSON config:

client_auth {
    mode require_and_verify
    trusted_ca_cert_file /etc/caddy/ca.crt

3. The problem I’m having:

This worked in Caddy 1, i changed the directive according to documentation. Public parts work, but iOS clients are never prompted for a client certificate and Caddy log shows requests without provided certificates.

4. Error messages and/or full log output:

2020/07/08 12:33:19 http: TLS handshake error from 65.154..:11537: tls: client didn’t provide a certificate

5. What I already tried:

Checking for errors in log, verifying public part of same config works.

6. Links to relevant resources:

This topic was automatically closed after 30 days. New replies are no longer allowed.