checkFdlimit and file decr. limit warning

checkFdlimit() emits:

		fmt.Printf("WARNING: File descriptor limit %d is too low for production servers. "+
			"At least %d is recommended. Fix with \"ulimit -n %d\".\n", rlimit.Cur, min, min)

Can we get rid of that? Or return an error which depending on the server type displays something along these line? I’ve got two issues with this:
a) it shows up on startup ever time I tests
b) I can’t silence it
c) It does not matter for DNS

Well three issues :slight_smile:

You should be able to slience it with the -quiet flag.

Good point about it not mattering for DNS servers only… I’ll see if I can add a check in there to only show if there are any TCP listeners.

I also have tcp listeners.

My point is also more along the lines - this might be stuff you need to know as an admin. There are a gazillion other things you need to know too - we don’t all printf those

True – I just added this warning since on its first day the Caddy website went down under the HN load, because I forgot to raise file descriptors limit. In fact I forget nearly every time to do it, even still. (I’m a bad sysadmin.)

So I have personally found this warning helpful… Caddy won’t admin your system for you but I just assumed this was a common error (I know it has helped save a couple other sites too from what I’ve heard). Is -quiet not sufficient/desirable?

I have just LimitNOFILE=8192 in my service file :smile:

But having the ability not not show this (on a serverType’s basis) would be welcome.

Well, one thing I can think of is if you’re running with -type=dns, for instance, you can also pass the -quiet flag and voila, disabled for the DNS server.