Cant Load Domain?

Your local DNS server needs to resolve the domain name to the IP address of your Caddy reverse proxy. It’s the same IP address that you specify in your port forward on the router.

??? could you eleborate my cloudflare runs my external ip adress of my home internet. Then i have a cname off the cloudflare linking to the domain name. Then a A record for home internet external ip adress using ipchicken. Are you saying i need to run my static ip that is running the jellyfin ie. localhost instead of 192.168.1.xxx. i also have my cloudflare NS on my domain registar linked to my domain.

What you have is a split DNS arrangement.

On the internet, Cloudflare acts as your external DNS resolver and resolves your domain name to your external IP address. Through port forwarding, your Caddy reverse proxy directs external clients to the correct local server.

On the private network, your local DNS resolver has to resolve the domain name to the IP address of the Caddy reverse proxy. The Caddy reverse proxy then directs local clients to the correct local server.

For more details, refer to the Wiki article Using Caddy as a reverse proxy in a home network

2 Likes

I read i need to setup a DYNAMIC DNS in my router configuartion using ddwrt third party firmware. like in here. router - Using dd-wrt Dynamic DNS client with CloudFlare - Server Fault
is that correct or could you go into more detail/example configuration ie dydns setup in ddwrt or like shown above at the link using the bottom post on that forum post

DynDNS is just one piece of the puzzle. That ensures that your domain always points to the correct IP for clients outside of your local network.

But while inside of your network, if you try to connect to your WAN IP, your router probably doesn’t understand how to loop back requests to the WAN IP back into the network to your server. Since you’re using DD-WRT, look around the settings for something called “NAT loopback” or “NAT redirection”, and make sure that’s turned on, that might fix the issue.

1 Like

aaah thank you i will test in a second. Two more questions. Do i need to port forward on router 8096 for ie jellyfin or 5000 for ombi, or can my workstation running barebones linux do that. Also if im running barebones and running docker inside the barebones OS. How do i run caddy from that docker if i already have my Caddyfile setup in my barebones OS. Do i need to run a caddy container and the caddy barebones? I would prefer to seperate certain apps in barebones and docker

No, you port forward 80 and 443 to your server running Caddy, and the rest of the ports stay internal to your local network. This is explained in this article:

1 Like

okay i already had that i just wanted to double check. I have enabled this setting which is the only one that i could find. is this correct.

Also I about the docker could you possibly answer that question asked here

its still not working??? Is there anything else I should be doing/enabling? I have give it 4+ hrs to propegate and still not loading my domains? Plus could you answer the docker question above

Are you still getting your router’s web page when you type in your domain, or is it simply not loading (i.e. timeout)?

Caddy doesn’t care whether it’s run in Docker or on the host itself. The same Caddyfile applies. You just need to ensure that Docker has ports 80/443 forwarded to Caddy’s container (the exact same concept as applies to forwarding 80/443 from your router to your server).

The only things that might need adjusting are webroots if you have those in relatively different locations inside the container, and upstreams (you’ll need to point those at adjacent containers and/or the host since localhost etc won’t work; looks like you use 192.168 addresses for upstreams, though, so this should probably be fine).

1 Like

its simply not loading now it just loads like the below picture

FYI: I changed stream.domain.com to tv.domain.com i made the required edits in Caddyfile and the cloudflare

Run this command:

dig TXT +short o-o.myaddr.l.google.com @ns1.google.com

Then run this command:

dig +short tv.movies4you.stream

And ensure they both produce the same IP address.

If they are the same, you likely need to revisit your router’s port forwarding.

1 Like

Yes they match

Heh, you weren’t meant to replace the myaddr part of that URL, it was literal.

But you got your own IP address anyway, so that’s fine.

It looks like the external port is closed. Either the ports are not forwarded, or they are but the recipient host has those ports closed as well.

so that was my orignal issue when i checked if the port was opened it said no even though i mirrored the same settings from my old network setup. I had this issue before in the past but i didnt document how i fixed it unfortunetly. ill share my port forward below.

Ive checked and tried a couple of fixes but cant figure out why my ports are still closed. Ive also reboot my router and modem multiple times to make sure the settings saved and correctly loaded on reboot as sometimes ddwrt hangs some settings until full reboot. Any ideas. btw im using the same internet company and I have full access to all ports as its a business line with Comcast. But my plan and data doesnt go through comcasts business lines. I get my internet from a provider that redistributes thier own packages for Comcast Businesss. They cant/wont block business internet ports unless it was for a specific reason.

Your “Port from” column is all zeroes.

It’s slightly ambiguous as to whether or not this is meant to be the external port or the start of the port range for the recipient internal host, but I think it’s meant to be the external port.

Looking at Google Images, there are examples of this field filled out in DD-WRT:

image

So it might be worth it to try populate the “Port from” field and see if that changes anything.

1 Like

OMFG!! Why Fricking me. The entire time was because of my ports literally loads instantly. I’m going to note for future reference both ports have to be opened like stated above to correctly forward the ports. I’m posting the picture below as reference if me or someone else has an issue in the future.
https://imgur.com/gallery/pJF1N8Z

I may still need help with docker can you leave this open. So I can correctly configure that or do you want me to open another help request post

Might be neater to open a second post, for posterity’s sake. But it’s not a huge deal, and nobody’s going to close the thread, so feel free to go either way.

okay yeah your 100% right. I will do rn. Thank you again!
EDIT 1: If anyone would like to know the answer to my docker caddy question here is the link to the other help request.