Can't connect to the website trough domain

Hi, Begginer to the Caddy here. Here is the thing:

1. The problem I’m having:

I want to deploy Flask Web App. I used Lightsail Ubuntu server with Caddy as my web server. Anyway, when i used only my ip to connect to the server, i could access it and viewed my web app. But when i connected it to the domain, and waited about 10 hours, i can’t access server with domain. DNS is connected because i dont have my domain provaider logo on front page. I tried contacting my provaider and he said to ask my IT supervisor (Which i dont have) to make my own DNS server (I have no idea). I checked my caddy files but it seems that its ok.

2. Error messages and/or full log output:

I dont get any error messages on my terminal

3. Caddy version:

v2.7.4 h1:J8nisjdOxnYHXlorUKXY75Gr6iBfudfoGhrJ8t7/flI=

4. How I installed and ran Caddy:

a. System environment:


b. Command:

source env/bin/activate - Activating Venv
cd Turizam - Changing directories
caddy stop
sudo caddy start- Properly starting caddy web server

d. My complete Caddy config: {
    reverse_proxy localhost:50100

5. Links to relevant resources:

Tutorial i used:

Well, i guess i don’t need to wait because I fixed it. My server didn’t have HTTPS which is automatically required for caddy i guess. Guy in tutorial even did it but i didnt catch that. Hope this helps someone

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.