Can't bind caddy to port 80 or 443

If have installed Caddy with an easy config but every time when I start Caddy it will not bind to port 80 or 443.
It always start on port 2015.

The output when I start Caddy is:
Activating privacy features… done.

I have already tried to use this command:
setcap cap_net_bind_service=+ep ./caddy

But I don’t know how to configure Iptables described in the FAQ.

I have running a Ubuntu 16.04 Vps.

Can you post the contents of your Caddyfile and the command you use to start Caddy?

This is the Caddy file:
root@flemming-petersen ~/caddy# cat conf.Caddyfile {
root /root/caddy

This is the command I use to start Caddy
root@flemming-petersen ~/caddy# ./caddy
Activating privacy features… done.

You need to specify the Caddyfile to use:

./caddy -conf conf.Caddyfile

By default, Caddy looks for a file called “Caddyfile” in the cwd.

nice now it works thank you very much

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.