Caddy2 logging setting

1. My Caddy version (v2.0.0-beta.13):


2. How I run Caddy:

Please provide all of the relevant information and DO NOT REDACT anything except passwords/keys. Thank you!

caddy run -config /etc/caddy/caddy.json

a. System environment:

OS, relevant versions, systemd? docker? etc.

CentOS 8 ,

b. Command:

caddy run -config /etc/caddy/caddy.json

c. Service/unit/compose file:

paste full file contents here

d. My complete Caddyfile:

paste Caddyfile here
DO NOT REDACT anything except credentials

3. The problem I’m having:

Now,your example just include app{},but the logging ,no example!!!
I have search all the google ,no one example how to write the logging { } config.
This my setting :
"sink": { "writer": { "file":{ "output": "file", "filename": "/etc/caddy/logs/sink.log", "roll": true, "roll_size_mb": 50, "roll_gzip": true, "roll_local_time": false, "roll_keep": 10, "roll_keep_days": 90 } } }

4. Error messages and/or full log output:

Please DO NOT REDACT any information except passwords/keys.

2020/02/16 05:53:42.395 INFO using provided configuration {“config_file”: “/etc/caddy/caddy.json”, “config_adapter”: “”}
2020/02/16 05:53:42.398 INFO admin admin endpoint started {“address”: “localhost:1000”, “enforce_origin”: false, “origins”: [""]}
run: loading initial config: loading new config: setting up sink log: loading sink log writer module: module name not specified with key ‘output’ in map[file:map[filename:/etc/caddy/logs/sink.log output:file roll:true roll_gzip:true roll_keep:10 roll_keep_days:90 roll_local_time:false roll_size_mb:50]]

5. What I already tried:

change my caddy.json

6. Links to relevant resources:

Most logs are on by default. They go to stderr. What are you trying to do, exactly? I don’t understand what you wrote.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.