Caddy stuck at "Activating privacy features" when redirecting www to non-www


(Borimir) #1

I’m trying to redir www to non-www but it doesn’t work.

My caddyfile is like this:

alston.top {
	root /home/alston/www/public
	tls yangjianfeng_11@126.com
	gzip
	log /home/alston/www/Caddylog/access.log
	errors /home/alston/www/Caddylog/error.log
	git {
		repo git@github.com:AlstonYang/AlstonYang.github.io.git
		path /home/alston/www/public
		key /home/alston/.ssh/id_rsa
		interval 100
		clone_args --recursive
		pull_args --recurse-submodules
	}
}

www.alston.top {
                redir alston.top
}

it works perfect without the second site. However, it stucks at “Activating privacy features…” when turning on caddy with the www site.

Anyone knows how to fix it? Thanks in advance.


(Toby Allen) #2

Is DNS pointing www.alston.top to your ip?

Can you run with logs so you can see what errors your getting

caddy -log stdout  

or

caddy -log logfile.log

(Borimir) #3

Thanks for your reply. I killed all caddy process and tried again and now it just works perfect. So my problem has been solved though I have no idea how it was been done:rofl: Thanks though


(Toby Allen) #4

Its worth running with -log option anyway, written to disk so if you have a problem you have a good log for trouble shooting