Caddy stopped issuing new certs

1. Caddy version (caddy version):


2. How I run Caddy:

Windows Service

a. System environment:

Windows 2019 DataCenter (VM on Azure)

b. Command:

c:\caddy\caddy.exe -agree=true -conf=c:\caddy\caddyfile

c. Service/unit/compose file:

d. My complete Caddyfile or JSON config:

proxy / {
tls {
	ask https://cp.[deleted].com/callbacks/caddy/ValidateCustomURL.aspx
root C:\caddy\www
#log C:\caddy\logs\caddy.log
#errors C:\caddy\logs\error.log

3. The problem I’m having:

Caddy runs OK but new certs are not created during the last 4 days (last cert was created 4 days ago).
The server is stable and didn’t have any maintenance or change during the last 2 years.
No CPU or memory issues, no Firewall cahnges.

When Caddy is trying to create new certs we see that it interacts with the ‘ask’ URL properly.
We’ve tried to restart the service with logs and errors enabled.
There was no error or and indication in the log file for the failure.

4. Error messages and/or full log output:

5. What I already tried:

Restarted the service with log and error enabled.
The errors file remained empty.
The log displayed the traffic but didn’t indicate any problem:

log C:\caddy\logs\caddy.log
errors C:\caddy\logs\error.log

6. Links to relevant resources:

Caddy v1 is EOL, and we no longer provide support for it. Please upgrade to Caddy v2.

I’ll be glad to upgrade today but this is our production server and we need some urgent help with that as our clients can’t work now…

Sorry, but v1 has been EOL since October 2020.

We have a few hundreds of certificates there. How can we upgrade keeping the certificates and the traffic? We would done that research ourselves but our production environment is not functioning now so we’re in a middle of a crisis. We’ll be glad to get any type of help, including a paid help.

Dear francis,

I’ve tried everything, called Ardan labs, sent an email and reviewed the docs.
Unfortunately I’m not technical enough to troubleshoot it or install Caddy2 myself and I wasn’t aware of that Caddy 1 is EOL.

What are my options to solve this issue today?

We use Caddy as a proxy server that generate SSL for all the incoming traffic of our clients.
Without that, our clients are offline. That’s a very complicated situation for me and I’m trying o reach out for help.

Thank you again,

This topic was automatically closed after 30 days. New replies are no longer allowed.