Caddy serves "old" request

I have this really weird error.

I used Caddy on multiple VPS but I’ve never experiences something like this.

After a certain amount of uptime, Caddy will serve a previous request.
An example to illustrate this weird behavior:

  1. You request /index.php - Response: empty
  2. You request /blog.php - Response empty
  3. You request /contact.php - Response index.php
  4. You go back to /index.php - It will show blog.php

Most of the times it will actually just show you the contents of a JS file or CSS file.

My stack is as followed:

  • Caddy 0.9.2
  • PHP-FPM (7.0)
  • PHP 7.0.11
  • MariaDB

The only error I can see that happens before this behavior is:
01/Oct/2016:10:46:38 +0200 [ERROR 502 /index.php] fcgi: invalid header version

After that many errors like these happen:
01/Oct/2016:10:46:40 +0200 [ERROR 502 /index.php] malformed MIME header line:</div><!-- END .wrap -->

PHP-FPM shows no errors.

The error vanishes when Caddy is restarted.

Does anyone have an idea how to debug this further?

Try upgrading to Caddy 0.9.3, then report back if this still happens.

I’ve upgraded to Caddy 0.9.3, I will report back if it has solved the issue.

1 Like

I had the same problem. Did upgrading to 0.9.3 solve the issue?

I had a similar issue that was solved by upgrade to 0.9.3


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.