Caddy on Windows 10 ARM

1. Caddy version (caddy version):

Latest version

2. How I run Caddy:

Not running Caddy yet

a. System environment:

Windows 10 ARM

b. Command:


c. Service/unit/compose file:



### 3. The problem I'm having:
I am looking for a Web Server for Windows 10 ARM and wonder if I can use Caddy and how. Anyone her that can point me in the right direction? 


### 4. Error messages and/or full log output:

### 5. What I already tried:


### 6. Links to relevant resources:

You can grab a build for Windows ARM on the download page:

Or you can build Caddy yourself from source using xcaddy (not hard, just install Go, install (or build with go build) xcaddy, then run xcaddy)


Thanks for the quick response. I have tried with both the Caddy 6 and 7 builds for Windows ARM, but it does not seem to run. When I execute the Caddy.exe file using e.g ‘version’ as a parameter, nothing happens. I copied the executable to C:\Caddy and excited it there from a command line.

Do I have to add C:\Caddy to my PATH Env variable or is it enough to set current dir to C:\Caddy?

A bit more info on my setup. I am running Windows 10 ARM Preview un a Parallels 16.5 virtual machine on a MacBook Air M1/Apple Silicon. Perhaps that is the cause of my problems?


Caddy is not a GUI application, it must be run from command line. You can run it from anywhere, just specify the path to the executable when running it.

You probably need an arm64 build, not arm6 or arm7, if you’re running on an M1 Mac. But it looks like this won’t be available until Go 1.17, since it was just added 15 days ago:

Or maybe if the x86 translation layer of the M1 might work? I dunno.


Wow, Francis. Don’t you ever sleep :slight_smile:. Again thanks for the quick reply. I am aware that there is no GUI for Caddy, but I was expecting just a list of options when I executed Caddy.exe if it had worked.

I will look forward to the ARM64 port.


Hi again.

Tried with the ‘regular’ AMD64 version and it seems to work. I can start and stop the server and I get a list of command line options when I just execute caddy.


It’s 5pm here :man_shrugging:

Nice :+1:

Off topic from the actual problem, but I’m curious:

Why run Caddy in Windows via virtualization when you could run it directly on the Mac?

1 Like

The reason, in short, is that some of the tools I use for work are Windows only and in this case, it requires that the HTTP/web server runs on Windows.

The longer answer is that I use the Windows only modeling tool Enterprise Architect from Sparx systems. They have products, ProCloudServer and WebEA, that makes it possible to browse the models and make minor changes to them via a Browser. To make that happen, the model needs to reside in an SQL database, e.g. MS SQL server, and ProCloudServer and WebEA, windows only programs, must be installed on the web server, which again requires that the WebServer runs under windows.

MAMP and XAMPP does not work in Windows 10 ARM and IIS is not yet ported by Microsoft, so I need another alternative. Can I make that happen, I can move my work and development completely to my M1 MacBook and not having to have my Intel MacBook with me just for testing WebEA and ProCloudServer stuff.

If it’s running in a VM, you can probably still run Caddy on Mac and proxy to the services that are in the Windows VM. That would also let you proxy to other things that are also run on your Mac.

Thats an option, but I would like to keep my setup as close as possible to my customers. Also I like to keep everything Windows contained inside the VM so everything is in one place. I actually have a VM per customer so I don’t contaminate across since they are on different versions of EA, are using different databases and also web servers.

Will be fun to see if it will work with Caddy. I will keep you posted

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.