Caddy linux amd64 not found in docker

1. Caddy version (caddy version):


2. How I run Caddy:

RUN curl --silent --show-error --fail --location
–header “Accept: application/tar+gzip, application/x-gzip, application/octet-stream” -o -” \

a. System environment:


b. Command:

RUN curl --silent --show-error --fail --location
–header “Accept: application/tar+gzip, application/x-gzip, application/octet-stream” -o -” \

#### c. Service/unit/compose file:
<!-- If using Docker/systemd/Kubernetes/make etc. -->

paste full file contents here

#### d. My complete Caddyfile or JSON config:

paste config here, replacing this text
DO NOT REDACT anything except credentials

### 3. The problem I'm having:
<!-- What are you trying to do, and what isn't working? Please describe the issue thoroughly enough so that anyone can reproduce the exact behavior you're seeing. Be as specific as possible. -->

### 4. Error messages and/or full log output:

curl: (22) The requested URL returned error: 404 

### 5. What I already tried:

### 6. Links to relevant resources:

Caddy v1 is no longer actively supported, and recently the v1 build server was taken offline.

Please upgrade to Caddy v2.

Also, the download page is not meant to be used to automated builds. Please instead download from Github instead Releases · caddyserver/caddy · GitHub or build from source with xcaddy or use the official docker images since you said you’re using Docker.

This topic was automatically closed after 30 days. New replies are no longer allowed.