Caddy 404 - Tearing out my hair


(Ross Ellner) #1

Hi

Firstly I apologise if this has been asked before - I have searched the focums but cannot find an answer.

I am VERY new to Caddy and have limited experience with coding so I am feeling my way through this.

I have Ombi set up to run though Docker on my Mac Mini and want to access it remotely.

I have my domain ombi.ellner.co.uk pointing to the IP of my mac and have caddy running with the below caddyfile.

ombi.ellner.co.uk {
proxy / 192.168.0.84:32768/
}

All I get is “404 Site ombi.ellner.co.uk is not served on this interface”

Can someone please tell me what I am doing wrong?

Thank you!


(Ross Ellner) #2

I also get the same result with:

www.ellner.co.uk {
proxy /ombi 192.168.0.84:32768/
}


(Matthew Fay) #3

Hi @SACEll,

Your Caddyfile definitely should be serving that site.

Can you let us know what command you use to run Caddy, and what its output is when you start it? It should print out a list of the sites it’s configured to serve.


(Ross Ellner) #4

Hi @Whitestrake

Thanks for the help!

I just type caddy in Terminal and get the below:

Plex-Server:~ rossellner$ caddy
Activating privacy features… done.
2018/07/04 22:21:27 listen tcp :2015: bind: address already in use
Plex-Server:~ rossellner$

To set it up originally I entered:

sudo caddy -host www.ellner.co.uk

and it returned http://www.ellner.co.uk & https://www.ellner.co.uk but I have not seen that in a while.


(Matthew Fay) #5

No worries. I can see there’s likely a few problems.

When Caddy gives you an error and returns to the prompt, that means it actually exited straight away (for the reason given). In this case, it tried to bind port 2015 and failed. At a guess, you’ve got another instance of Caddy still running on the system, configured with an old Caddyfile, hence the “Site not served” errors.

Kill the old Caddy process with pkill -SIGTERM caddy and then try to launch it again from the command line. Use -conf /path/to/Caddyfile flag to make sure it picks up the correct configuration. If Caddy starts successfully, the command will block and you won’t get another prompt in your terminal until you exit Caddy. During that time, it should print out the site labels in your Caddyfile.


(Ross Ellner) #6

OK, I’ve killed all processes but when I try to direct it to the caddyfile I get the below:

Plex-Server:~ rossellner$ caddy -conf ~/Applications/caddy/caddyfile
2018/07/05 22:21:31 loading Caddyfile via flag: open /Users/rossellner/Applications/caddy/caddyfile: no such file or directory
Plex-Server:~ rossellner$

The caddyfile is in a directory called Caddy in the Applications folder of my user. Its a plain text file.

Thanks for your help. I’m sure you have better things to do than help a guy who knows NOTHING!!


(Matthew Fay) #7

Hmm, Caddy doesn’t seem to think a Caddyfile exists at that file path.

Double check that the file is actually present at the location you expect and modify your -conf flag, or move the file, as appropriate.


(Ross Ellner) #8

Very odd. Still no luck.

I have:-
Deleted the caddyfile and recreated it from scratch
Deleted caddy entirely from the machine and reinstalled to /usr/bin
Caddy & caddyfile are both in the same location
If I start with caddy I get:-

“Activating privacy features… done.
http://:2015
WARNING: File descriptor limit 256 is too low for production servers. At least 8192 is recommended. Fix with “ulimit -n 8192”.”

If I use caddy -conf /usr/bin/caddyfile I get:-

“Plex-Server:~ rossellner$ caddy -conf /usr/bin/caddyfile
2018/07/06 13:37:17 loading Caddyfile via flag: open /usr/bin/caddyfile: no such file or directory
Plex-Server:~ rossellner$”


(Matthew Fay) #9

OK, that’s really weird indeed.

What distro are you running, and what’s your caddy -version?