Caddy 1.0 and not 2.0 on github for ARMV7?


1. Caddy version (caddy version):

Caddy 2.0

2. How I run Caddy:


a. System environment:

Raspberry 3b+ + Raspbian

b. Command:

connected to my Raspberry with Putty and on /home/pi
I retrieved from GitHub and untar archive to get Caddy 2 binary with following commands:

wget “
tar -xvf “caddy_2.0.0_linux_armv7.tar.gz”
caddy -version

3. The problem I’m having:

I executed from /home/pi, command below,

caddy -version

i got:


i expected get :

v2.0.0 or more

4. Error messages and/or full log output:


5. What I already tried:

i deleted tar.gz and caddy binary from /home/pi
i reloaded again but i got same version.

6. Links to relevant resources:

See page with last 2.0 Caddy tar.gz package list.

Do you have explanation for why i’ve got v1 instead v2 Caddy from a tar.gz named 2.0
Is there an error of package?

Hi Tom! Welcome around :wave:

I bet that’s the old Caddy executable you have laying around. Can you try this command?
./caddy version

If that works, then the downloaded file is correct. You will have to copy this file to where the old Caddy was. To know where it is in your operating system, run which caddy. It will give you the location of where the Caddy executable is.

Thanks a lot.
./caddy version i got 2.0 !
then with command which caddy, i got /usr/local/bin/caddywhich is what is set in my caddy.service.

I replace with new caddy by mv caddy /usr/local/bin
then reboot my Raspberry.
And great,
caddy version returned 2.0
thanks a lot.
Issue is closed.
There was conflict of Caddy.


Just FYI, you don’t have to reboot the computer. Just moving the new version and restarting Caddy is enough.

1 Like

yes sure but wanted to test all was OK with new Caddy 2 started.
Thanks Nicolinux.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.