Annke CCTV box behind reverse proxy wont play feeds

1. Caddy version (caddy version):

latest windows 64 version

2. How I run Caddy:

as a reverse proxy

a. System environment:

windows 10

b. Command:


d. My complete Caddyfile or JSON config: {
    encode gzip
        log {
            output file d:\caddy\logs\mc.masshate_access.log {
                roll true               # Rotate logs, enabled by default
                roll_size_mb 5          # Set max size 5 MB
                roll_gzip true          # Whether to compress rolled files
                roll_local_time true    # Use localhost time
                roll_keep 2             # Keep at most 2 log files
                roll_keep_days 7        # Keep log files for 7 days

3. The problem I’m having:

I can load up the cctv login page (using internet explorer as its the only broswer that the cctv viewer plugin supports), login and it loads the UI as normal then I press play to start the cctv feeds.
nothing happens.

whenever i use the internal address it works fine and displays the feeds

4. Error messages and/or full log output:

internet explorer has a warning in the console regarding an unexpected token and points to this line

other than that nothing shows up in the log file

5. What I already tried:

sacrifed a chicken to the gods of tech

other than that im not that smart when it comes to this kind of thing I usually just google copy paste and cross my fingers.

6. Links to relevant resources:

Are you sure it was unblemished?

Which line?

Sorry i guess i didnt add the backticks

<script id="seajsnode" src="../script/lib/seajs/seajs/sea-2.1.1.min.js"></script>

I now have some errors in the error log which are as follows

2020/12/04 18:23:48.721	error	http.log.access.log4	handled request	{"request": {"remote_addr": "", "proto": "HTTP/2.0", "method": "GET", "host": "", "uri": "/doc/script/lib/angularjs/angularjs/", "headers": {"Accept": ["*/*"], "Accept-Language": ["en-GB,en;q=0.5"], "Accept-Encoding": ["gzip, deflate"], "User-Agent": ["Mozilla/5.0 (Windows NT 10.0; WOW64; Trident/7.0; rv:11.0) like Gecko"], "Cookie": ["language=en"]}, "tls": {"resumed": false, "version": 771, "cipher_suite": 49196, "proto": "h2", "proto_mutual": true, "server_name": ""}}, "common_log": " - - [04/Dec/2020:18:23:48 +0000] \"GET /doc/script/lib/angularjs/angularjs/ HTTP/2.0\" 404 166", "duration": 0.0295274, "size": 166, "status": 404, "resp_headers": {"Server": ["Caddy", "DNVRS-Webs"], "Cache-Control": ["no-cache"], "Content-Length": ["166"], "Content-Type": ["text/html"], "Date": ["Fri, 04 Dec 2020 18:23:46 GMT"]}}```

This topic was automatically closed after 30 days. New replies are no longer allowed.